Решить по информатике! 25 составить программу,которая определяет сколько слагаемых должно быть в сумме последовательности 2+4+6+8+.. и эта сумма оказалась больше заданного числа n. n> =0паскаль,8 класс!

swetadasa swetadasa    3   17.04.2019 16:27    3

Ответы
максимилиан123098 максимилиан123098  07.06.2020 19:16

var

 i, c, s, n:integer;

Begin

 write('Введите n: ');

 readln(n);

 s:= 0;

 c:= 0;

 write('Последовательность: ');

 while i < n do begin

   s:= s + i;

   c:= c + 1;

   i:= i + 2;

   write(i, ' ');

 end;

 writeln;

 writeln('Сумма последовательности: ', s);

 writeln('Количество слагаемых: ', c);

END.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика