Решить: напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 5 или 9. программа программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 ( 0- признак окончания ввода не входит в
последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30000. программа должна вывести одно число: количество чисел кратных 5 или 9. ​

ТвояЗайка111 ТвояЗайка111    3   08.10.2019 01:20    13

Ответы
SkeetNZ SkeetNZ  10.10.2020 03:05

я вроде уже решал такую задачу... Ту в условиях только добавилась фраза "по модулю". Скорректировал программу с учетом уточнения в задании.

var

   a, n, i : integer;

begin

   repeat

       read(a);

       if (abs(a) <= 30000) and (a <> 0) then begin

           if (a mod 5 = 0) or (a mod 9 = 0) then n += 1;

           i += 1;

       end;

   until (a = 0) or (i = 1000);

   writeln(n);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика