решить на языке Python Рассматривается множество целых чисел, принадлежащих числовому отрезку [2481; 14832], которые делятся на 5 или 11 и не делятся на 6, 7, 10, 23. Найдите количество таких чисел и максимальное из них. В ответе запишите два целых числа без пробелов и других дополнительных символов: сначала количество, затем максимальное число.

begk55 begk55    3   21.05.2021 20:12    46

Ответы
movsisjan88 movsisjan88  20.06.2021 20:13

A = []

x = 0

y = 0

count = 2481

while count <= 14832:

   if count % 5 == 0 and count % 11 == 0 and count % 6 != 0 and count % 10 != 0 and count % 23 != 0:

       x += 1

       A.append(x)

count = 0

while count <= len(A):

   if y < int(A[count]):

       y = int(A[count])

   count += 1

print(x, y)

ну по идее воть))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика