Решить на турбопаскале: 1.дано натуральное число найти сумму и произведение первых двух чисел. 2.дано n-значное натуральное число. правда ли что квадрат произведения цифр числа равняется кубу суммы цифр числа. 3.составить программу, которая печатает таблицу умножения и сложения натуральных чисел в десятичной системе счисления.

victoria128 victoria128    1   24.05.2019 07:20    9

Ответы
hanabi7suzuha hanabi7suzuha  20.06.2020 03:25
Program  Kasyanova98_1;
uses crt;
var n,nt,p:integer;
  begin
  writeln('***   Alphaues is thinking...   ***');
  write('Ok, введите натуральное число N = ');
  readln(n);
  nt:=n;
  while nt>=10 do
    begin
      p:=nt;
      nt:= nt div 10;
    end;
  writeln('Cумма первых двух цифр числа ',n,' равна ',(p div 10)+(p mod 10));
  writeln('Произведение первых двух цифр числа ',n,' равно ',(p div 10)*(p mod 10));
end.

Program  Kasyanova98_2;
uses crt;
var n,nt,sum,kw,temp:integer;
  begin
  writeln('***   Alphaues is thinking...   ***');
  write('Ok, введите натуральное число N = ');
  readln(n);
  nt:=n;
  sum:=0;
  kw:=1;
  while nt>=1 do
    begin
    temp:=nt mod 10;
    sum := sum + temp;
    kw:=kw * temp;
    nt := nt div 10;
  end;
  if kw*kw=sum*sum*sum then
      writeln('Квадрат произведения цифр числа ',n,' равняется кубу суммы его цифр')
    else
writeln('Квадрат произведения цифр числа ',n,' НЕ равняется кубу суммы его цифр');
end.

Program Kasyanova98_3.1;
uses crt;
const n=10;
var
  x,y:integer;
begin
  writeln('');
  writeln('*                   ТАБЛИЦА УМНОЖЕНИЯ                  *');
  writeln('');
  write('*    * ');
  for y:=1 to n do
    begin
      write(y:2);
      if y<n then write(' | ')
      else      writeln(' * ');
    end;
  writeln('');
  for x:=1 to n do
    begin
      write('* ',x:2, ' * ');
      for y:=1 to n do
         begin
          write(x*y:2);
          if y<n then write(' | ')
        end;
        if x*y<100 then writeln(' * ')
                   else writeln('* ');
        if x<10 then writeln('++')
                else writeln('');
    end;
end.

Program Kasyanova98_3.2;
uses crt;
const n=10;
var
  x,y:integer;
begin
  writeln('');
  writeln('*                   ТАБЛИЦА СЛОЖЕНИЯ                   *');
  writeln('');
  write('*    * ');
  for y:=1 to n do
    begin
      write(y:2);
      if y<n then write(' | ')
      else      writeln(' * ');
    end;
  writeln('');
  for x:=1 to n do
    begin
      write('* ',x:2, ' * ');
      for y:=1 to n do
         begin
          write(x+y:2);
          if y<n then write(' | ')
        end;
        if x+y<100 then writeln(' * ')
                   else writeln('* ');
        if x<10 then writeln('++')
                else writeln('');
    end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика