Решить на составление программы линейной структуры с переменной: 1. заработок рабочих на фабрике составил 624750 руб. его нужно разделить поровну между а рабочих и k служащих. выведите заработок каждого работника. 2. мальчик может бегать в 3 раза быстрее, чем ходить. скорость его ходьбы равна y км/ч. он принял участие в марафонском забеге, но сошел с дистанции, пробежав только x км. сколько времени он затратил на преодоление этого расстояния.

tattysg tattysg    3   18.09.2019 06:40    25

Ответы
konovalovilya konovalovilya  26.08.2020 22:55
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

№1

begin
  var (a,k):=ReadInteger2('Укажите количество рабочих и служащих:');
  Writeln('Заработок работника равен ',624750/(a+k))
end.

Пример
Укажите количество рабочих и служащих: 15 6
Заработок работника равен 29750

№2

begin
  var y:=ReadReal('Укажите скорость ходьбы, км/ч:');
  var x:=ReadReal('Мальчик пробежал, км: ');
  Writeln('Затрачено времени на бег, ч: ',x/(3*y):0:2)
end.

Пример
Укажите скорость ходьбы, км/ч: 5.2
Мальчик пробежал, км:  12
Затрачено времени на бег, ч: 0.77
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика