РЕШИТЬ НА PYTHON
1. Введите с клавиатуры значения элементов массива, увеличьте каждый элемент в 2 раза и выведите полученный массив на экран.
2. Введите с клавиатуры значения элементов массива и увеличьте на 5 значения всех элементов массива, кроме первого и последнего.
3. В массиве чётное число элементов. Введите с клавиатуры значения элементов массива, и выполните две операции:
а) увеличьте на единицу значения всех элементов в первой половине массива;
б) увеличьте в 2 раза значения всех элементов во второй половине массива.
4. Введите с клавиатуры значения элементов массива и найдите их среднее арифметическое. 5.Напишите программу, которая заполняет массив случайными числами на отрезке
[–2; 2] и считает сумму положительных элементов массива.
6.Напишите программу, которая заполняет массив случайными числами на отрезке
[2; 10] и считает отдельно количество чётных и нечётных элементов.
7.Напишите программу, которая заполняет массив случайными числами на отрезке
[1000; 2000] и считает количество элементов, в десятичной записи которых вторая с конца цифра (число десятков) – чётная.

Катюшка311001 Катюшка311001    2   24.04.2020 16:18    147

Ответы
Skynet14 Skynet14  13.10.2020 20:20

Aaaf

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Дафааааааа Дафааааааа  13.10.2020 20:20

Объяснение:

1.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

new_array = []

for thing in a:

   new_array.append(int(thing) * 2)

print(new_array)

2.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

new_array = []

last_elem = int(a.pop())

counter = 0

for thing in a:

   if counter == 0:

       new_array.append(int(thing))

       counter += 1

   else:

       new_array.append(int(thing) * 5)

new_array.append(last_elem)

print(new_array)

3.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

part = int(len(a) / 2)

new_array = []

for thing in a[:part]:

   new_array.append(int(thing) + 1)

for thing in a[part:]:

   new_array.append(int(thing) * 2)

print(new_array)

4.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

print(sum([int(number) for number in a]) / len(a))

5.

import random

numbers = range(-2, 3)

random_array = random.sample(numbers, random.randint(1, 4))

positive = [numb for numb in random_array if int(numb) > 0]

print(sum(positive))

6.

import random

numberss = range(2, 11)

numbers = random.sample(numberss, random.randint(1, 9))

d = {"Чётные": 0, "Нечётные": 0}

for thing in numbers:

   if int(thing) % 2 == 0:

       d["Чётные"] += 1

   else:

       d["Нечётные"] += 1

print(f"Масив: {numbers}")

print(", ".join([f"{v}: {d[v]}" for v in d]))

7. Не сильно понял задачу, можно объяснить по-подробнее?)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика