Решить на паскаль с постусловием дано натуральное число m. написать программу для вычисления первой цифры числа m. входные данные 54321 выходные данные 5. дано натуральное число m. написать программу для вычисления второй цифры числа м(m> 10) входные данные 54321 выходные данные 4.

Valeria12351778 Valeria12351778    1   08.08.2019 15:50    8

Ответы
egame egame  04.10.2020 05:18
Var
    m, i: integer;
    a: array[1..10] of integer;

begin
    readln(m);
    i := 0;
    repeat
        i := i + 1;
        a[i] := m mod 10;
        m := m div 10;
    until m = 0;
    
    writeln('Первая цифра ', a[i]);
    writeln('Вторая цифра ', a[i - 1]);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика