Решить эту . (написать программу на языке c++) . в некотором государстве в обращении применяются купюры достоинством 1, 5, 10, 50, 100, 500 и 1000 единиц. сколькими можно разменять купюру достоинством 1000 единиц? найти количество всех простых чисел в диапазоне от 2 до 100 000.

Dilya0608 Dilya0608    2   07.09.2019 22:40    2

Ответы
Миланахасик Миланахасик  06.10.2020 23:50
"Найти количество всех простых чисел в диапазоне от 2 до 100 000", - решение через Решето Эратосфена.
#include <iostream>
#include <vector>
using namespace std; 
 
int main()
{
    unsigned a = 0, b = 0;
    cin >> a >> b;
    vector<char> v(b + 1, '1');
     for (unsigned i = 3; i < v.size(); i += 2) {
        for (unsigned j = i + i; j < v.size(); j += i) {
            vec[j] = '0';
        }
    }
 
    if (a == 2) {
        cout << 2 << " ";
    }
   
    a += !(a&1);

    for (unsigned i = a; i < v.size(); i+=2){
        if (vec[i] == '1') {
            cout << i << " ";
        }
    }
    return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика