Решить это на любом языке программирования. Напишите программу, на вход которой с клавиатуры в первой строке подается натуральное число n ‐ количество показаний прибора (n<12000). Начиная со второй строки, подаются сами показания прибора ‐ целые числа из диапазона [10, 21999999] по одному в строке. Программа должна вывести в порядке убывания те из них, которые меньше среднего арифметического всех показаний.

denus16 denus16    1   26.06.2020 18:49    2

Ответы
Gogi354 Gogi354  15.10.2020 14:57

Написал Вам код на Python-е, держите (также прилагается скриншот с самим кодом и выводом компилятора для наглядного ориентира):

n = int(input('Enter the number of readings of the device: n = '))

readings_list = []

for num_of_readings in range(1,n+1):

       prompt_row = 'Enter ' + str(num_of_readings) + ' reading: '

       reading = int(input(prompt_row))

       readings_list.append(reading)

arithm_mean = 0

for num_of_readings in range(n):

   arithm_mean += readings_list[num_of_readings]

arithm_mean /= n

selected_values_list = []

selected = 0

for num_of_readings in range(n):

   if (readings_list[num_of_readings] < arithm_mean):

       selected = readings_list[num_of_readings]

       selected_values_list.append(selected)

selected_values_list.sort(reverse = True)

if (len(selected_values_list) == 0):

   print('There is no values that are less than the arithmetic mean')

else:

   print('Values that are less than the arithmetic mean - ',*selected_values_list,sep = '  ')


Решить это на любом языке программирования. Напишите программу, на вход которой с клавиатуры в перво
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика