tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Решить, дано двумерный массив
Решить, дано двумерный массив целых чисел. вычислить сумму всех отрицательных элементов массива и добавить его к третьему элементу массива во втором столбце решить с функциями с++
МарияLevkivska
1 21.09.2019 12:50
3
Ответы
Slonik3452
08.10.2020 07:08
#include <iostream>
#include <array>
#include <random>
using namespace std;
mt19937 gen { random_device()() };
uniform_int_distribution<> uid(-20, 20);
constexpr size_t N = 5;
int main()
{
int sum = 0;
array<array<int, N>, N> a;
for (auto &i : a) {
for (auto &j : i) {
if ((j = uid(gen)) < 0) {
sum += j;
}
cout << j << "\t";
}
cout << endl;
}
cout << endl;
a[1][2] += sum;
for (const auto &i : a) {
for (const auto &j : i) {
cout << j << "\t";
}
cout << endl;
}
cout << "Sum: " << sum << endl;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
olegovnao27
01.12.2021 16:07
Зделайте верхнию упражние нпишите атветы на казаском...
martin37
01.12.2021 16:12
Миша написал сообщение в месенджере своей бабушке. Бабушка , мама с папой собираются на море , а меня брать не хотят. Можно я приеду к тебе? Мощность компьютера алфавита...
angelochec1999
26.06.2019 12:00
Какой текст будет выведен на экран в результате выполнения следующего фрагмента программы? s: = example ; s0: = abc ; delete(s,1,3); writeln(s);...
Лиза45111
19.05.2019 03:00
Значения двух массивов a[1..10] и b[1..10] с следующего фрагмента программы: for i: =1 to 10 do a[i]: =10-i; for i: =1 to 10 do b[i]: =a[5] – a[i] сколько элементов...
sdgsdgsdgsdgsdg228
19.05.2019 03:00
Придумайте кодированияцветов 32 цветной палитры...
daniil9211
18.10.2020 13:39
Каждая страница учебника содержит 20 строк, в каждой строке 40 символов. Учебник состоит из 80 страниц. Определите информационный объем учебника в килобайтах, битах,...
veronik09
18.10.2020 13:40
Найдите наибольшее значение в списке и индекс последнего элемента, который имеет данное значение за один проход по списку, не модифицируя этот список и не используя...
Даша1707
18.10.2020 13:25
Что относится к основным частям компьютер?...
МахитоТ
18.10.2020 13:25
Текст занимает 4 байта Определите информационный объём в битах...
ПолинаКорышкова
18.05.2020 20:28
Решите уравнение за не правильные ответы спам...
Популярные вопросы
Составь предложение из данных слов: весной, родные, птиц , с потеплением,...
1
2. Как меняются природные комплексы вашей местностипод влиянием...
2
Қайдасың қасұа құлыным идеясы?...
2
буть ласко не одной ошибок решите...
1
127 сабақ 120 бет 4 сынып 38-39 жаттығу жауаптары керек көмек...
2
. Очень надо люди добрые) Буду благодарен....
2
Переделайте рассказ о друге в женский род Voici le portrait de...
1
На всех стадиях своего развития человек былтесно связан с коружающим...
1
ТУТ БЫСТРО как могут быть расположены две плоскости α и β , если...
3
Два муравья бегают по окружности навстречу друг другу. Пока один...
2
#include <array>
#include <random>
using namespace std;
mt19937 gen { random_device()() };
uniform_int_distribution<> uid(-20, 20);
constexpr size_t N = 5;
int main()
{
int sum = 0;
array<array<int, N>, N> a;
for (auto &i : a) {
for (auto &j : i) {
if ((j = uid(gen)) < 0) {
sum += j;
}
cout << j << "\t";
}
cout << endl;
}
cout << endl;
a[1][2] += sum;
for (const auto &i : a) {
for (const auto &j : i) {
cout << j << "\t";
}
cout << endl;
}
cout << "Sum: " << sum << endl;
}