tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Решить дан массив a[5].найти
Решить дан массив a[5].найти наименьший положительный элемент среди элементов с четными номерами массива.
Maximka200117
1 28.05.2019 15:50
1
Ответы
datskivvera
26.06.2020 08:58
VB.
Dim A(5) As Integer
Dim min As Integer = A(0)
For i As Integer = 1 To A.Length - 1
If i Mod 2 = 0 Then
If A(i) > 0 And A(i) < min Then
min = A(i)
End If '
End If
Next
Pascal.
const n=5;
var
a: array[1..n] of byte;
i,imin: byte;
begin
writeln('Исходный массив:');
for i:=1 to n do
begin
a[i]:=random(21);
write(a[i],' ');
end;
writeln;
imin:=1;
for i:=2 to n do
begin
if a[i]<a[imin] then imin:=i;
end;
writeln('Минимум = ',a[imin]);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
yuliasolarova
15.03.2019 17:10
Цветное (с палитрой 64 цветов) растровое графическое изображение имеет размер 54х30 точек. какой информационный объем имеет изображение (ответ запишите в битах)?...
Ринацой
28.06.2019 04:10
Свойства обьекта(стола),существенные с точки зрения изготовителя и потребителя:...
newumnik
22.06.2019 00:30
Дан текст из 600 символов. известно что символы берутся из алфавита мощностью 512 символов. определит информационный объем текста в битах....
varvara124
22.06.2019 00:30
Компьютерный вирус удаляет каждую минуту половину всего объема информации, хранящейся на usb-флеш-накопителе. на usb-флеш-накопителе было 8000000 байт файлов. через какое наименьшее...
Killy2
22.06.2019 00:30
Решить кроссворд по информатике: 1. об єкт, що вказує на поточне місце в документі (6 букв) 2. об єкт вікна word 2007, де розміщено основні елементи керування об єктами (7 букв)...
Wensansys
22.06.2019 00:30
Электронная книга в кодировке кои-8 (мошьность компьютерного алфавита равна 256) содержит 150 страниц , на каждой странице-40 строк, в каждой строке 60 символов. каков объем книги...
Aidanok1
30.07.2020 15:23
Напишите условие на любом языке программирования для проверки попадания вводимой точки.A(x, y) в область, ограниченную функциями f1(y) =0.5, f2(y) = 3.5, f3(x) =sin(x), f4(y) =cos(x)....
31.07.2020 15:27
Какой из перечисленных языков программирования является машинно-ориентированным? 1) Cobol 2)Basic 3)Assembler 4)Fortran...
AQUA111
31.07.2020 15:17
Что из ниже перечисленного используется для создания web-сайтов: 1)С++ 2)Assembler 3)Basic 4)php...
katruhanchik
30.07.2020 15:50
написать программу в Pascal. Нужно чтобы пользователь ввёл число из десятичной системы, а программа переводила его в двоичный код....
Популярные вопросы
Task 1. Listen to the text. Find the mistake, underline it and write the correct...
2
Найдите значение производной функции g(x)=7x^3-2x в точке...
2
Турфирма вводит скидку 3% всем покупателям. Объем продаж до ввода скидки 2122000...
3
1.Как еще называют Норвегию и почему ? 2.Какая форма правления в Норвегии ?...
3
памагите режить : 2+2=ω 5+4= ω 10-1-4=ω...
2
Укажите ряд с количественными числительными А) пятеро, седьмой Б) пятый, один...
2
Наступление экологическое , продовольственного , ресурсного кризисов . Вымирание...
1
Написать анализ фильма легенда №17....
3
I can talk about now/ (Present Simple)...
2
Одна из высот параллелограма =12см.Надите сторону к которой проведена эта высота,если...
2
Dim A(5) As Integer
Dim min As Integer = A(0)
For i As Integer = 1 To A.Length - 1
If i Mod 2 = 0 Then
If A(i) > 0 And A(i) < min Then
min = A(i)
End If '
End If
Next
Pascal.
const n=5;
var
a: array[1..n] of byte;
i,imin: byte;
begin
writeln('Исходный массив:');
for i:=1 to n do
begin
a[i]:=random(21);
write(a[i],' ');
end;
writeln;
imin:=1;
for i:=2 to n do
begin
if a[i]<a[imin] then imin:=i;
end;
writeln('Минимум = ',a[imin]);
end.