РЕШИТЬ ЧЕРЕЗ С++

Написать программу, которая бы по введенному номеру единицы измерения (1 — дециметр, 2 — километр, 3 — метр, 4 — миллиметр, 5 — сантиметр) и длине отрезка L выдавала бы соответствующее значение длины отрезка в метрах.

trollotrollovit trollotrollovit    3   24.03.2020 07:44    15

Ответы
skata9196 skata9196  12.10.2020 03:22

#include <iostream>

int main()

{

int n;

float l;

std::cin >> n >> l;

switch (n)

{

case 1:

 std::cout << "Length: " << l / 10;

 break;

case 2:

 std::cout << "Length: " << l * 1000;

 break;

case 3:

 std::cout << "Length: " << l;

 break;

case 4:

 std::cout << "Length: " << l / 1000;

 break;

case 5:

 std::cout << "Length: " << l / 100;

 break;

default:

 break;

}

std::cout << std::endl;

system("pause");

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика