Решить 1. напишите программу, вычисляющую площадь прямоугольника. с клавиатуры вводятся два действительных числа - стороны прямоугольника. необходимо вычислить его площадь и вывести на экран. вывод должен быть отформатирован следующим образом: под число отводится 10 знаков, а под вещественную часть - 3. 2. с клавиатуры вводятся 3 целых числа. определить количество положи¬тельных чисел в этом наборе.

Assel0802 Assel0802    3   26.07.2019 03:40    6

Ответы
SAHARIA SAHARIA  03.10.2020 13:10
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
{
программа, вычисляющая площадь прямоугольника.
}
var
  a,b: real;

begin
  write('Стороны прямоугольника ');
  read(a,b);
  writeln(' Площадь фигуры = ',a*b:10:3);
end.

Тестовое решение:
Стороны прямоугольника 5.3 6.7
 Площадь фигуры =     35.510

{
С клавиатуры вводятся 3 целых числа.
Определить количество положительных чисел
в этом наборе.
}
var
  a,i,n: integer;

begin
  for i:=1 to 3 do begin
  write(i,'число = ');readln(a);
  if a>0 then n:=n+1;
  end;
  writeln(' Положительных :',n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика