Решето эратосфена в pascalabc данные вводятся с клавиатуры или из файла input.txt, выводятся на экран или в файл output.txt. первые тесты не всегда с примерами из условия. напишите программу, которая выводит все простые числа в диапазоне от 2 до n включительно ( 2 ≤ n ≤ 100000 ). входные данные входная строка содержит целое число n ( 2 ≤ n ≤ 100000 ). выходные данные программа должна вывести все простые числа в диапазоне от 2 до n в одну строку, разделив их пробелами. примеры входные данные : 20 выходные данные : 2 3 5 7 11 13 17 19

ritakosyanenko ritakosyanenko    3   06.09.2019 05:00    5

Ответы
viklya30 viklya30  06.10.2020 20:40
Program n1;
var n,i: longint;
function simply(a: longint ):boolean;
var i: longint;
begin
simply:=true;
for i:=2 to trunc(sqrt(a)) do begin if a mod i=0 then begin
simply:=false;
break
end
end
end;
begin
readln(n);
for i:=2 to n do if simply(i) then write(i,' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика