Ребят, очень нужна Написать программу перевода целого числа из 10с.с. В 2с.с.
(Паскаль)

KendallK KendallK    3   13.05.2020 20:55    4

Ответы
alex1439 alex1439  14.10.2020 17:34

program ss102;

var a,b,c,i,v:integer;

begin

readln(a);

v:=0;

b := a;

while a > 0 do begin

b = b div 10;

c = c + 1;

end;

for i:=0 to c do begin

b:=a mod 2;

a:=(a-b) div 2;

v:=v + b*exp(i*In(10));

end;

writeln(c);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика