РЕБЯТ НАДОО!! Ниже приведена программа, записанная на пяти языках программирования.

Бейсик

DIM s, t, A AS INTEGER

INPUT s

INPUT t

INPUT A

IF s > 10 OR t > A THEN

PRINT "YES"

ELSE

PRINT "NO"

ENDIF
Python
s = int(input())

t = int(input())

A = int(input())

if (s > 10) or (t > A):

print("YES")

else:

print("NO")

Паскаль

var s,t,A: integer;

begin

readln(s);

readln(t);

readln(A);

if (s > 10) or (t > A)

then

writeln ('YES')

else

writeln ('NO')

end.
Алгометрический язык
алг

нач

цел s, t, A

ввод s

ввод t

ввод A

если s > 10 или t > A

то вывод "YES"

иначе вывод "NO"

все

кон

С++

#include

using namespace std;

int main() {

int s, t, A;

cin >> s;

cin >> t;

cin >> A;

if(s > 10) or (t > A)

cout << "YES" << endl;

else

cout << "NO" << endl;

return 0;

}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(1, 2); (11, 2); (1, 12); (11, 12); (−11, −12); (−11, 12); (−12, 11); (10, 10); (10, 5).

Укажите количество целых значений параметра A, при которых для указанных входных данных программа напечатает «NO» три раза.

natalia04062001 natalia04062001    1   21.12.2020 19:02    92

Другие вопросы по теме Информатика