Ребат составить программу . составьте программу, которая заполняет одномерный целочисленный массив из 50 элементов случайным образом в диапозоне от 1до 60, выводит массив на экран в строку, затем- четные элементы складывает, нечетные элементы перемножает, после чеговыводит сумму и произведение. блок схему к ней, если можно, заранее .

kurzinovaa kurzinovaa    3   24.08.2019 19:50    3

Ответы
kidashapro kidashapro  05.10.2020 17:14
Var
    a: array[1..100] of integer;
    i, n: integer;
    sum, product, harmonic: real;

begin
    n := 50;
    
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        a[i] := random(60);
        write(a[i], ' ');
    end;
    writeln();
    
    {подсчет суммы и произведения и агригатов}
    sum := 0;
    product := 1;
    for i := 1 to n do
        if i mod 2 = 0 then
            sum := sum + a[i]
        else
            product := product * a[i];
    writeln('sum = ', sum);
    writeln('product = ', product);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика