tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Реализовать программу исследования
Реализовать программу исследования квадратного уравнения . коэффициенты a, b и c вводятся с клавиатуры на языке си++
nastiadair
2 23.06.2019 10:40
3
Ответы
КираГринРоуз
19.07.2020 10:53
#include <iostream.h>
#include <math.h>
int main()
{
int a, b, c;
long long d;
cout << "Vvedite a: "; cin >> a;
cout << "\nVvedite b: "; cin >> b;
cout << "\nVvedite c: "; cin >> c;
d = b * b - 4 *a * c;
if (d > 0) cout << "x1 = " << (-b + sqrt(d))/(2*a) << "\n" << "x2 = " << (-b - sqrt(d))/(2*a) << endl;
else if (d == 0) cout << "x = " << -1.*b/(2*a) << endl;
else if (d < 0) cout << "Korney net" << endl;
system("pause");
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
tyoma2223333
01.10.2019 17:00
Вкажіть властивості файлового вірусу.(може бути декілька) а)у кіненць файлу корисної програми він дописує команду переходу на власне тіло б)на початок файлу корисної...
yoanna0900
12.12.2021 17:32
преобразуйте решение задачи в код python...
ekaterina791
12.12.2021 17:31
Как решить с ботами я не могу ошибка @bot.message_handler(content_types=[ start ]) AttributeError: str object has no attribute message_handler...
Вкорма
12.12.2021 17:31
Запишите числа в беззнаковом коде, формат 1 байт 31 163 65 128 Как это вообще делать?...
pronikich
23.04.2020 18:45
Задание 1Для построения диаграммы в таблице необходимо выделить:Выберите один из 4 вариантов ответа:1) числовые данные;2) итоговую строку;3) боковик таблицы;4) шапку.Задание...
Molderjkee
23.04.2020 18:45
МНЕ ЧЕРЕЗ 20 МИНУТ СДАВАТЬ...
WDGa5ter
23.04.2020 18:45
Для кодирования одного из цветов палитры служит двоичный код 1101. Сколько цветов содержит палитра? *очень и всё обЪяснить...
southpaw40
23.04.2020 18:44
Составить программу нахождения количества целых чисел кратных 3 на интервале от 1 до 100. прописать комментарий к программе очень надо...
elenakovaleskau
23.04.2020 18:44
1. У чому полягає зміст багаторівневої нумерації? * 1Елементи списку нумеруються залежно від абзацу 2Елементи списку нумеруються залежно від рівня вкладеності 3Елементи...
sas4ha
23.04.2020 18:44
умоляю умоляю умоляю меня мама убьёт если я не сделаю!...
Популярные вопросы
Составьте распространённые предложения со словами: шахматистка,...
1
Дом занимает одну пятнадцатую садового участка. ниайдите площадь...
3
Твір- міркування чи подобається тобі весна?...
3
Как правильно? what is a capital или what is the capital...
3
Определить по склонениям слово ремешок...
1
Выполни преобразования 3856ц= т ц 12306кг= ц кг...
3
Какая это пропорциональная зависимость прямая или обратная? решение...
2
9-4+3 надо сначала прибавить,или вычитать?...
1
Найдите число, сумма которого и удвоенного квадрата этого числа...
2
22. неметаллические свойства наиболее выражены : 1)у хлора 2)у...
3
#include <math.h>
int main()
{
int a, b, c;
long long d;
cout << "Vvedite a: "; cin >> a;
cout << "\nVvedite b: "; cin >> b;
cout << "\nVvedite c: "; cin >> c;
d = b * b - 4 *a * c;
if (d > 0) cout << "x1 = " << (-b + sqrt(d))/(2*a) << "\n" << "x2 = " << (-b - sqrt(d))/(2*a) << endl;
else if (d == 0) cout << "x = " << -1.*b/(2*a) << endl;
else if (d < 0) cout << "Korney net" << endl;
system("pause");
return 0;
}