Разработать в виде программи алгоритм вычисления взаимного расположения точки и прямой(pascal)

ekozhushkova ekozhushkova    3   23.07.2019 10:10    5

Ответы
asya159 asya159  25.08.2020 12:58
Uses Crt; var x,y,x1,y1,x2,y2:integer; Begin Clrscr; Writeln('Задайте: x,y,x1,y1,x2,y2'); Readln(x,y,x1,y1,x2,y2); If (abs(x-x1)+abs(x2-x)=abs(x2-x1)) and (abs(y-y1)+(abs(y2-y)=abs(y2-y1)) then Writeln('точка принадлежит отрезку') Else Writelb('точка не пренадлежит отрезку') Readln End.
ПОКАЗАТЬ ОТВЕТЫ
zhan1205 zhan1205  25.08.2020 12:58
Для задания произвольной прямой на плоскости будем использовать уравнение:
A*x+B*y+C=0;
Тогда, зная коэффициенты (A, B, C) в уравнении прямой и координаты точки X, Y можно будет сделать вывод о расположении прямой и точки.

var a,b,c,x,y:real;
begin
  writeln('Введите коэффициенты прямой a,b,c');
  readln(a,b,c);
  writeln ('Введите координаты точки x,y');
  readln(x,y);
  if (a*x+b*y+c)=0 then writeln ('Точка лежит на прямой')
  else writeln ('Точка не лежит на прямой');
end.

Тест №1
Введите коэффициенты прямой a,b,c
2 4 -8
Введите координаты точки x,y
-4 4
Точка лежит на прямой

Тест №2
Введите коэффициенты прямой a,b,c
2 4 -8
Введите координаты точки x,y
1 4
Точка не лежит на прямой
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика