Работа цикл for(для паскаля) 1.составить программу,которая выводит на экран таблицу деления числа 11 на целые от 1 до 10(с 2мя знаками после запятой). 2.составить таблицу значени функции y=x^3+2 на отрезке [-5; 5] с шагом 1.

yanashowsouany yanashowsouany    2   27.06.2019 20:20    4

Ответы
Sadist702 Sadist702  22.07.2020 08:59
// Составить программу, которая выводит на экран таблицу деления числа 11 на целые от 1 до 10(с 2мя знаками после запятой).  

var x: real;
     i: word;
begin
   writeln('Таблица деления числа 11 на целые от 1 до 10(с 2мя знаками после запятой)');
   for i:=1 to 10 do   begin
        x:=11/(i);
        writeln('11/',i,' =',x:0:2);
    end;
end.    

// Со<span class="_wysihtml5-temp-placeholder"></span>ставить таблицу значений функции y=x^3+2 на отрезке [-5;5] с шагом 1.
var x,y: real;
         i: shortint;  
begin
   writeln('Таблица значений функции y=x^3+2 на отрезке [-5;5] с шагом 1.');   
   for i:=(-5) to 5 do
      begin
         y:=i*i*i+2;
         writeln('При х=',i,' y=',y);
    end; 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика