PYTON Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом.

bacongurl1 bacongurl1    1   28.01.2021 22:07    22

Ответы
stoyanovadsДарья stoyanovadsДарья  27.02.2021 22:11

Решение в лоб:

x = int(input())

lucky = x % 10

check = False

x //= 10

while x > 0:

   if x % 10 == lucky:

       check = True

       break

   else:

       lucky = x % 10

   x //= 10

if check == False:

   print("Одинаковых цифр,стоящих рядом нет!")

else:

   print("Есть одинаковые цифры, стоящие рядом!")

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика