Python Треугольник Паскаля Даны два числа n и m. Создайте массив × и заполните его по следующим правилам: Числа, стоящие в строке 0 или в столбце равны 1 (A[0][j] = 1, A[i][0] = 1). Для всех остальных элементов массива A[i][j] = A[i-1][j] + A[i][j-1], то есть каждый элемент равен сумме двух элементов, стоящих слева и сверху от него. Входные данные Вводятся два натуральных числа n и m , не превышающих 100. Выходные данные Выведите данный массив на экран. Примеры Ввод 3 3 Вывод 1 1 1 1 2 3 1 3 6

slunyavchik slunyavchik    1   04.08.2020 17:54    39

Ответы
ksomarova777 ksomarova777  15.10.2020 15:44

n, m = map(int, input().split())

A = [[0]*m for i in range(n)]

for i in range(m):

   A[0][i] = 1

for i in range(n):

   A[i][0] = 1

for i in range(1, n):

   for j in range(1, m):

       A[i][j] = A[i-1][j] + A[i][j-1]

for i in range(n):

   print(*A[i])

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика