Python с цикла while! Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — максимальное число, кратное 5.

Сельга7 Сельга7    3   17.12.2021 16:06    1

Ответы
maksimgrig12 maksimgrig12  17.12.2021 16:10

n = int(input())

maxc = -100000000

while n > 0:

   a = int(input())

   if a % 5 == 0:

       maxc = max(maxc,a)

   n -= 1

print(maxc)

ПОКАЗАТЬ ОТВЕТЫ
silverfinn silverfinn  17.12.2021 16:10

x = int(input())

a = 0

z = 0

lel = ':)'

while a < x:

   a += 1

   f = int(input())

   if f%5:

       if lel == ':)':

           lel = f

       else:

           lel = max(lel,f)

print(lel)

Если есть вопросы, пиши

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика