Python Напишите программу, в которой пользователь вводит строки до тех пор, пока не будет введена пустая строка "".  При вводе каждой непустой строки, программа должна выводить "текст". 

Входные данные:

Ввод текста в отдельных строчках.

Выходные данные:

Выводить "текст" до пустой строки.​

вася772 вася772    2   15.07.2020 18:57    7

Ответы
sofika121 sofika121  15.10.2020 15:23

--- Python 3.8.3 ---

import typing

from typing import Callable

from typing import Any

Primitive = typing.TypeVar('Primitive', int, float, complex, str, bytes, bytearray)

def ReadSeqWhile(predicate: Callable[[Any], bool], SeqType: Primitive = int):

   '''

   Возвращает последовательность элементов в указанном типе, считываемых с клавиатуры, пока ввод удовлетворяет условию

   '''

   temp = SeqType(input())

   while predicate(temp):

       yield temp

       temp = SeqType(input())

def main():

   InputData = ReadSeqWhile(lambda p: p != '', SeqType = str)

   for _ in InputData:

       print('text')

   

if __name__ == "__main__":

   main()

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика