(Python) написать программу, которая считывает числа, вводимые пользователем, пока пользователь не введёт слово “end”. Предполагайте, что пользователь вводит только целые числа или слово “end”. В конце программа должна вывести все введённые числа через запятую и их сумму и среднее значение.
Пример вывода
Enter numbers:
1
10
25
-1
0
3
67
end
You entered: 1, 10, 25, -1, 0, 3, 67
Total: 105
Average: 15.0
Указания:
Используйте цикл while для ввода чисел и сохраняйте их в списке.
Используйте цикл for для подсчёта суммы чисел в полученном списке.

машуня89 машуня89    2   31.03.2020 10:17    88

Ответы
nmh788 nmh788  12.10.2020 10:08

lst = []

count = 0

sm = 0

while True:

   try:

       lst += [int(input())]

   except:

       break

print('You entered:', end=' ')

for i in lst:

   sm += i

   count += 1

   if i != lst[-1]:

       print(i, end=', ')

   else:

       print(i)

print(f'Total: {sm}')

print(f'Average: {sm / count}')

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика