Python, информатика | По данному числу n закончите фразу «На лугу пасется...» одним из возможных продолжений: «n коров», «n корова», «n коровы», правильно склоняя слово «корова».

Формат входных данных
Дано число n (n≤99).
Формат выходных данных
Программа должна вывести введенное число n и одно из слов (на латинице): korov, korova или korovy, например, 1 korova, 2 korovy, 5 korov. Между числом и словом должен стоять ровно один пробел.

homyak8 homyak8    1   12.12.2020 08:25    28

Ответы
Юлдуз1122 Юлдуз1122  12.12.2020 08:30

n:integer;

begin

readln(n);

If (n >= 11) and (n <= 14) then write(n, ' korov') else

case n mod 10 of

0, 5..9: write(n, ' korov');

1: write(n,' korova');

2..4: write(n, ' korovy');

end;

end.

Объяснение: ну в вроде как-то так.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика