Python Импортируйте numpy.

Создайте матрицу (2D-массив) случайных действительных чисел (тип с плавающей запятой) размерности (5, 7). Случайные числа должны быть от 0 до 1. Отобразите эту матрицу.

Найдите минимальное и максимальное значения матрицы и отобразите эти значения с соответствующим сообщением.

Создайте массив действительных чисел длины 5, который должен содержать минимальное значение каждой строки предыдущей матрицы: первое значение массива должно содержать минимальное значение первой строки массива, второе значение массива должно содержать минимальное значение второй строки матрицы и т. д.

Отобразите эти минимальные значения с соответствующими сообщениями.

Сделала только это пока что :
import numpy as np

random_matrix_array = np.random.uniform(0, 1, size=(5, 7))
print(random_matrix_array)

random_matrix_array.min()
print("Минимум", random_matrix_array.min())

random_matrix_array.max()
print("Максимум :", random_matrix_array.max())

айсу17 айсу17    3   12.02.2021 17:47    1

Ответы
ilia9999999999 ilia9999999999  14.03.2021 18:42

Сделал не через numpy, как смог:

from random import random

matrix = [[random() for j in range(5)] for i in range(7)]

print('Матрица: \n', str(matrix)[1:-1].replace('], ', '\n').replace('[', '').replace(']', '').replace(',',' '), sep='')

print('Минимальное значение =>', max(max(matrix[i]) for i in range(7)))

print('Максимальное значение =>', min(min(matrix[i]) for i in range(7)))

min_mass = []

for g in matrix:

   min_mass += [min(g)]

print('Минимальные значения каждой строки пред. матрицы =>', min_mass)

Но хотя бы работает

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика