Python и главное чтобы программа с работой. напишите программу, которая вычисляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.

German1224 German1224    3   18.04.2019 08:55    28

Ответы
Савина11 Савина11  30.09.2020 13:31

#a)

print('Input n: ')

n = input()

if int(n) < 0:

   print('Incorrect input')

else:

   sum = 0

   for i in range(int(n) + 1):

       sum += i

   print('Sum is ', sum)

##

#b)

print('Input n: ')

n = input()

if int(n) < 0:

   print('Incorrect input')

else:

  sum = 0

  for i in range(int(n) + 1):

      sum += i*i

  print('Sum is ', sum)

##

#c)

print('Input n: ')

n = input()

if int(n) < 0:

   print('Incorrect input')

else:

   sum = 0

   for i in range(0, int(n) + 1, 2):

       sum += i

   print('Sum is ', sum)

##

#d)

sum = 0

for i in range(10, 100, 1):

   sum += i

print('Sum is ', sum)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика