Python Дано число n. Напишите программу, которая изменяет это число до 1 следующим образом. Если число четное, то делит его на 2, а иначе умножает на 3, увеличивает на 1, а затем делит результат на 2. Например, если число равно 5, то после первого изменения оно станет равно (5⋅3+1)/2 = 8.

Считайте целое положительное число n. Выведите результаты изменения числа по описанным правилам, каждое – в отдельной строке.

черныйхащ черныйхащ    2   04.03.2022 04:03    9

Ответы
anka110 anka110  04.03.2022 06:00

n = int(input())

while n != 1:

   if n % 2 == 0:

       n //= 2

   else:

       n = (n * 3 + 1) // 2

   print(n)

(я не уверена, что верно поняла задачу)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика