Python. Циклы for и while. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO). Последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). 30 б.

kazashkatv kazashkatv    3   15.02.2021 22:12    53

Ответы
leha262006 leha262006  17.03.2021 22:13

x, s, counter = -1, 0, 0

while x != 0:

   x = int(input())

   if (x>=100) and (x<=999):

       s += x

       counter += 1

if counter == 0:

   print("NO")

else:

   print(s/counter)

ПОКАЗАТЬ ОТВЕТЫ
pep4 pep4  17.03.2021 22:13

numbers = []

while True:

   num = int(input('Введите число: '))

   if num == 0:

       break

   if len(str(num)) == 3:

       numbers.append(num)

if numbers != []:

   s = 0

   for num in numbers:

       s += num

   print('Среднее арифметическое:', s / len(numbers))

else:

   print('NO')

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика