Python. 70 . решить с циклов. 1) найдите все пятизначные числа, которые при делении на 133 в остатке 125, а при делении на 134 в остатке 111. 2)натуральное число называется числом армстронга, если сумма цифр числа, возведенных в n-ную степень (где n – количество цифр в числе) равна самому числу. например, 153 = 13 + 53 + 33. найдите все трёхзначные армстронга. 3)натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. например, 252 = 625. напишите программу, которая получает натуральное число n и выводит на экран все автоморфные числа, не превосходящие n.

rada182 rada182    3   17.07.2019 10:40    19

Ответы
mr1cherry mr1cherry  03.10.2020 06:21
#задание 1
for i in range(10000,100000):
    if ((i % 133 == 125) & (i % 134 == 111)):
         print(i)

#задание 2
s=0
for i in range(100,1000):
    n=i
    while (n>0):
        s+=pow(n % 10,3)
        n=n // 10
    if (s==i):
        print(i)
    s=0

#задание 3
n=int(input('задайте N: '))
for i in range(1,n):
    d=10
    while (i>=d):
        d=d*10 
   if ((i*i % d)==i):
        print('число ',i,'квадрат ',i*i) 
       
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика