Python 3 нужно написать программу которая будет вычислять факториал 100000 и после него выводить количество нулей в конце данного факториала, а также время за которое исполняется программа
алгоритм должен выполниться быстрее чем приведенный ниже как минимум в 1.5 раза


Python 3 нужно написать программу которая будет вычислять факториал 100000 и после него выводить кол

NikNameXxX NikNameXxX    2   06.12.2020 22:42    11

Ответы
starkoviv23 starkoviv23  05.01.2021 22:43

import time

start_time = time.time()

y = int()

fct = int(1)

z = int(0)

for i in range(1, 100001):

   fct *= i

   y = i

   while ((y % 5) == 0):

       z += 1

       y /= 5

print(fct)

print(z)

print("--- %s seconds ---" % (time.time() - start_time))

input()

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика