Python ! 1) Сгенерировать список из 10000 случайных элементов, значения от 0 до 99 (через бибилотеку random),
после чего вывести среднее арифметическое этих элементов,
сумму всех элементов, которые делятся на 10 без остатка и если сумма этих элементов меньше 600, вывести значение последнего элемента массива.
2) Написать программу, которая на вход получает слово, и добавляет к нему восклицательный знак, выовдит получившуюся строку.

ваня2007123 ваня2007123    3   03.04.2021 14:12    4

Ответы
Азека2008 Азека2008  03.04.2021 14:20

1)import random

s = [random.randint(0,99) for i in range(10000)]

sum = 0

for i in s:

   sum += i

print("Среднее арифметическое:", sum/10000)

sum = 0

for i in s:

   if i % 10 == 0:

       sum += i

if sum < 600:

   print(s[len(s)-1])

else:

   print("Сумма всех элементов, которые делятся на 10 без остатка:",sum)

2)s = input()

print(s+"!")

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика