PYTH На вход программы получаем число X. Причём 10000<= X <=1000000

Напишите программу, которая находит сумму цифр числа на чётных местах и сумму цифр числа на нечётных местах (места нумеруем с 0 и справа на лево). Например:

987851

Сумма чётных = 17

Сумма нечётных = 21

kbvovap0drsr kbvovap0drsr    2   09.12.2021 17:25    1

Ответы
rtydykov rtydykov  28.01.2022 14:41

x = input('X: ')

summach = 0

summanech =0

for i in range(1, len(x)+1):

   if i % 2 == 0:

       summach += int(x[i-1])

   else:

       summanech += int(x[i-1])

print('Сумма чётных = ' + str(summach))

print('Сумма нечётных = ' + str(summanech))

Чуть поменял прогу.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика