Пропустил тему по программированию на paskalabc. информатика 10 кл. дали нужно решить 6 . 1) наименьшее из двух чисел. даны 2 числа х и у. найти меньшее из них. если числа равны, то вывести сообщение об этом. 2) частное любых чисел. напишите программу, которая запрашивет два целых числа и выводит запись операции их деления. предусмотрите в программе защиту от аварийной ситуации деления на нуль. 3) фамильярность. напишите программу, которая читает строку, и если это ваше имя то печатает на экране ! а если нет, то ! (учтите что у каждого автора программы скоё имя) 4) чётность числа. напишите программу которая определяет является ли число чётным. 5) символ строки с проверкой. напишите программу выводящую символ с заданным номером из введенной строки. если символа с таким номером нет, то программа должна напечатать слова: нет символа! 6) больше фруктов. одно яблоко весит 100 гр., а один апельсин 150 гр.вам заданное кол-во яблок или заданное кол-во апельсинов. хочется взять то что весит больше. напишите программу , подсказывающую, что лучше взять, яблоки или апельсины? пример 7 ябл. 5 апельс. вывод: берите апельсины! заранее за !

Айхан1111111111 Айхан1111111111    3   21.06.2019 11:10    4

Ответы
Egor162007 Egor162007  16.07.2020 23:56
Задача 1
var
x,y:integer;
begin
  writeln('Введите х');
  readln(x);
  writeln('Введите y');
  readln(y);
  if x<y then writeln('Меньшее: ',x) else
  if x>y then writeln('Меньшее: ',y) else
  if x=y then writeln('Числа равны')
end.

задача 2
var
x,y:integer;
begin
  writeln('Введите первое число');
  readln(x);
  writeln('Введите второе число');
  readln(y);
  if y=0 then writeln('Второе число равно 0. Деление невозможно!') else
  writeln(x,'/',y,'=',x/y);
end.

задача 3
var
s,name:string;
begin
  writeln('Введите ваше имя');
  readln(name);
  writeln('Введите строку');
  readln(s);
  if s=name then writeln('Привет!') else
  writeln('Здравствуйте!');
end.

задача 4
var
x:integer;
begin
  writeln('Введите число');
  readln(x);
  if (x mod 2)=0 then writeln('Четное') else writeln('Нечетное')
end.

задача 5
var
x:string;
i:integer;
begin
  writeln('Введите строку');
  readln(x);
  writeln('Введите номер символа');
  readln(i);
  if i > length(x) then writeln('Нет символа!') else writeln(x[i])
end.

задача 6
var
x,y:integer;
begin
  writeln('Количество яблок:');
  readln(x);
  writeln('Количество апельсинов:');
  readln(y);
  if (x*100)>(y*150) then writeln('Берите яблоки')
  else
  if (x*100)<(y*150) then writeln('Берите апельсины')
  else
  if (x*100)=(y*150) then writeln('Вес яблок и апельсинов одинаковый')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика