Программы паскаля составьте программу решения квадратного уравнения ax2 +bx +c=0 коэффициенты a в с введите с клавиатуры. выведите на экран значения корней x1 x2 если уравнение имеет два корня, значение x, если уравнение имеет один корень, или сообщение "нет корней", если уравнение не имеет корней.

valera242 valera242    2   12.06.2019 00:40    5

Ответы
назик31 назик31  09.07.2020 19:25
Var
  a, b, c, d, x1, x2: real;

begin
  Write('Введите через пробел значения a,b,c: ');
  Readln(a, b, c);
  d := sqr(b) - 4 * a * c;
  if d < 0 then Writeln('Нет действительных корней')
  else if d = 0 then Writeln('Один корень ', -b / (2 * a))
  else
  begin
    d := sqrt(d);
    x1 := (-b - d) / (2 * a);
    x2 := (-b + d) / (2 * a);
    Writeln('x1=', x1, ', x2=', x2)
  end
end.

Тестовое решение:
Введите через пробел значения a,b,c: 4 3.2 -2
x1=-1.2124038404636, x2=0.412403840463596

ax^2+bx+c=0 \\ D=b^2-4ac \\ x= \frac{-b\mp \sqrt{D}}{2a}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика