Программу на языке pascal: для ремонта кабинета шириной а метров, длиной b метров, высотой h метров необходимо купить в магазине обоев. площадь окон и дверей не учитывать. известна стоимость одного рулона (86 рублей) обоев длиной 12 м и шириной 0,6 м. составьте программу определяющую, какая сумма необходима для покупки обоев.

ssnn70p0aegz ssnn70p0aegz    1   28.05.2019 22:30    5

Ответы
katunina2004ox971p katunina2004ox971p  01.10.2020 13:47
Program olraisinsss;
const n=86; z=12; c=0.6;
var a,b,h,p1,sum:integer;   
     p2:real;
begin
write('a=');read(a);
write('b=');read(b);
write('h=');read(h);
p1:=4*(b+h)+4*(a+h);

while p2<p1 do begin
p2:=p2+2*(z+c);
sum:=sum+1;
end;
writeln('Price=',sum*n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика