Программу через паскаль планы по благоустройству города иногда имеют свойство воплощаться в жизнь. вот, к примеру, раньше кеше, чтобы добраться до бассейна, приходилось переходить одну широкую дорогу. а теперь наземного перехода больше нет, зато есть подземный переход. правда, расстояние, которое приходится преодолевать по подземному переходу, в несколько раз больше, чем было по наземному. но есть и плюсы — бывает, начинает накрапывать дождь, а пока спустишься в переход, пройдёшь его, поднимешься — а дождь уже успел превратиться в ливень, пролиться, и выглянувшее солнце сушит лужи. маршрут кеши от дома до бассейна выглядит следующим образом. сначала кеша идёт по улице в течение d минут, потом идёт по подземному переходу в течение w минут, после чего вновь идёт по улице в течение p минут. известно, что, пока кеша шёл в бассейн дождь длительностью u минут. дождь начался не ранее момента, в который кеша вышел из дома, и закончился не позднее того момента, когда кеша дошёл до бассейна. ваша — определить, какое максимальное и какое минимальное время кеша мог идти под дождём. входные данные в первой строке содержатся целые числа d, w, p, u (1 ≤ d, w, p ≤ 1000, u ≤ d + w + p), описанные в условии . выходные данные выведите два целых числа — максимальное и минимальное время, которое кеша мог идти под дождём. пример входные данные 14 10 8 15 выходные данные 14 5

polina3510 polina3510    2   05.08.2019 17:20    6

Ответы
marinamashkina2 marinamashkina2  03.10.2020 23:43
Var  d, w, p, u: integer;
begin  read(d);  read(w);  read(p);  read(u);  if u <= d + w then  begin    write(d, ' ');    write(u - w);  end  else if u > d + w + p then  begin    write(p + d,' ');    write(p + d);  end  else   begin    write(u - w,' ');    write(p);  end;end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика