Программисты !
(program pr1) ! паскаль.

составить программу: данно трехзначное число (например 4 5 6). получить число, в котором цифры стоят в обратном порядке (6 5 4) ​​

Arina4dyuzhova Arina4dyuzhova    3   07.10.2019 23:14    2

Ответы
Винокуров1998 Винокуров1998  11.08.2020 15:21

uses

 Math;

var

 n, r, i, d: Integer;

begin

 Write ('Введите трехзначное число: ');

 ReadLn (n);

 r := 0;

 d := 100;

 if (n >= 100) and (n <= 999) then begin

   for i := 1 to 3 do begin

     r := r + (n mod 10) * d;

     n := n div 10;

     d := d div 10;

   end;

   WriteLn ('Результат = ', r);

 end else

   WriteLn ('Это не трехзначное число');

 ReadLn;

end.

Объяснение:

для 3 цифр в цикле выделяются единицы, десятки, сотни.

умножается на d: в цикле меняется 100, 10, 1

результат суммируется в r

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика