Программисты, нужно написать программу на паскале дано натуральное число n. найти произведение нечетных чисел от 1 до n. c longint и integer.

Dobro118 Dobro118    1   25.09.2019 03:10    4

Ответы
Babaev11 Babaev11  08.10.2020 17:15
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  Writeln(Range(1,ReadInteger,2).Aggregate(BigInteger(1),(p,q)->p*q))
end.
ПОКАЗАТЬ ОТВЕТЫ
Kate00013 Kate00013  08.10.2020 17:15
Var
  n, i: integer;
  pr: longint;

begin
  readln(n);
  pr := 1;
  i := 1;
  while (i <= n) do begin
    i := i + 2;
    pr := pr * i;
  end;
  pr := pr div i;
  writeln(pr);
end.
Программисты, нужно написать программу на паскале дано натуральное число n. найти произведение нечет
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика