Программирование с условным оператором
Коробочка имеет форму прямоугольного параллелепипеда с размерами X, Y, Z радиусом R. Составить программу, которая при указанных данных напечатает результат и какой стороной влезет.
Пример: ввести размеры и радиус: X=3, Y=5, Z=7, R=10
Составить условие для проверки прохождения коробочки.
Печать ответа: "Коробочка влезет" или "Коробочка не влезет"

vladkoblov02 vladkoblov02    3   15.04.2020 13:14    4

Ответы
Masha15122006 Masha15122006  06.08.2020 23:25

program box;

var

 x, y, z, r: integer;

 d: real;

begin

 writeln('Введите первую сторону коробочки');

 readln(x);

 writeln('Введите вторую сторону коробочки');

 readln(y);

 writeln('Введите третью сторону коробочки');

 readln(z);

 writeln('Введите радиус отверстия');

 readln(r);

 d := r * 2;

 if (sqrt(x * y * z) <= d) then writeln('Коробочка пройдет в круглое отверсие радиуса ', r)

 else writeln('Коробочка не пройдет в круглое отверстие радиуса ', r);

 readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика