Программирование (Питон ,
Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число. (Питон)
Числа вводятся через input, а также, для последовательности, нужен цикл for

Екатерина200017 Екатерина200017    1   26.05.2021 05:31    48

Ответы
Шекспир112005 Шекспир112005  25.06.2021 06:32

Python

n=int(input('Введите количество чисел : '))

a=[0]*n

for i in range(n):

   a[i]=int(input('a['+str(i)+']='))

z=999999

for i in a:

   if z>i and i%2==0:

       z=i

if z!=999999:

   print('минимальное чётное число=', z)

else:

   print('Чётных чисел не найдено')

# 2 вариант с использованием sorted    

n=int(input('Введите количество чисел : '))

a=[0]*n

for i in range(n):

   a[i]=int(input('a['+str(i)+']='))

a=sorted(a)

for i in a:

   if i%2==0:

       print('минимальное чётное число=', i)

       break

   


Программирование (Питон , Напишите программу, которая в последовательности натуральных чисел опреде
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика