Программирование на языке си! любую из этих программ: 1. составить программу, которая определяет произведение цифр четырехзначного числа, введенного пользователем. 2составить программу, которая запрашивает у пользователя целочисленные корни многочлена четвертой степени и, используя теорему виета, находит его коэффициенты. вывести результат в форме таблицы, где первая строка – степени, а вторая – коэффициента при этих степенях.

danlestern danlestern    1   02.08.2019 04:30    5

Ответы
polinakolesnik4 polinakolesnik4  29.09.2020 22:23
1. #include <stdio.h>#include <ctype.h>
int main(int argc, char** argv){    char a, b, c, d;    if (scanf("%c%c%c%c", &a, &b, &c, &d) != 4)        printf("Input error\n");    else    {        if (isdigit(a) && isdigit(b) && isdigit(c) && isdigit(d) && (a > '0'))            printf("Sum is %d\n", a + b + c + d - 4 * '0');        else            printf("Is itn't correct number\n");    }    return 0;}
ПОКАЗАТЬ ОТВЕТЫ
RMDEL RMDEL  29.09.2020 22:23
1. Программа (без проверки правильности ввода):
#include <stdio.h> 

int main() 

   int N;
   scanf ("%d", &N); 
   int sum; 
   sum = N/1000 + N/100%10 + N%100/10 + N%10;
   printf ("sum = %d",sum);
}

Пример:
5029
sum = 16
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика