Программирование на Python. Звездный треугольник

Дано нечетное натуральное число nn. Напишите программу, которая печатает равнобедренный звездный треугольник с основанием, равным nn в соответствии с примером:

*
**
***

***
**
*

Формат входных данных
На вход программе подается одно нечетное натуральное число.

Формат выходных данных
Программа должна вывести треугольник в соответствии с условием.

Примечание. Используйте вложенный цикл for!

​

motidzukiakane motidzukiakane    2   09.06.2020 19:53    332

Ответы
duwie duwie  15.10.2020 13:33

nn = int(input())

x = ''

for i in range(1, nn // 2 + 2):

   x = ''

   for z in  range(i): x += '*'

   print(x)

mas = [None] * (nn // 2)

m = 0

for i in range(0, nn // 2): mas[i] = '*' * (i + 1)

for i in range(0, len(mas)):

   m = len(mas) - i - 1

   print(mas[m])

можно было-бы сделать все в 3 строки, но чего-то нельзя в for сделать шаг в обратную сторону

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика