Программирование на Python
дано натуральные числа m и n. Составить программу для нахождения всех их общих делителей

gasi20022 gasi20022    2   06.05.2020 22:47    2

Ответы
qwwwq0 qwwwq0  14.10.2020 09:15

Відповідь:

n = int(input("n = "))

m = int(input("m = "))

q = 0

p = []

while True:

   q += 1

   c = n%q

   d = m%q

   if c == 0 and d == 0:

       p.append(q)

   if q>m or q>n:

       break

print("Все общие делители - ", p)

Пояснення:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика