tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Программа запрашивает у пользователя
Программа запрашивает у пользователя числа а,б,с. далее происходит решение квадратного уравнения на основе этих чисел и вывод результатов. c#
krasnov595egr
1 03.09.2019 03:50
4
Ответы
Rima02
06.10.2020 13:51
Using System;
namespace Test
{
public class Program
{
public static void Main(string[] args)
{
double a,b,c,D,x1,x2;
a=double.Parse(Console.ReadLine());
b=double.Parse(Console.ReadLine());
c=double.Parse(Console.ReadLine());
D=b*b-4*a*c;
if(D>=0){
x1=(-b+Math.Sqrt(D))/(2*a);
x2=(-b-Math.Sqrt(D))/(2*a);
Console.WriteLine("x1="+x1+"; x2="+x2);
}
else Console.WriteLine("нет корней"); }
}
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
НастяФем
21.03.2021 21:55
Складіть алгоритм і блок-схему обчислення значення виразу у=х^5 Перевод:составьте алгоритм и блок-схему вычисления значения выраженияу=х^5...
isaevavika
12.05.2020 20:07
Как сделать горку и качели в скетчап ход работы...
Гриимитсичень
12.05.2020 20:07
решите программу на языке Си Написать программу, которая выдает таблицу значений функции Y = 6x2 + arctg(x), угол вводится в градусах. Перевод угла в радианы предусмотреть...
nicekuzia01
12.05.2020 20:06
Ниже приведена программа, на одном из языков программирования. Алгоритмический язык алг нач цел s, k ввод s ввод k если s = а и k – 2 то вывод ДА иначе вывод НЕТ...
валерия832
20.09.2020 20:00
СОСТАВИТЬ ПРОГРАММУ НА ПИТОНЕ Дано натуральное число n. Составить программу вывода цифр, не входящих в десятичную запись числа n (в порядке возрастания). Например:...
Kyivua777
20.09.2020 20:57
Какова мощьность алфавита, с которого записано сообщение, содержащее 3072 символа, если его объём составляет 3 кбайт...
Шишеа
20.09.2020 20:55
Визначити значення властивостей процесорів, які доступні на ринку Харківського регіону. ...
Wow01
30.07.2019 21:40
Как называется прозрачная нить, используемая для передачи световых сигналов, в том числе и в компьютерных сетях....
Masha8157
30.07.2019 21:40
Составьте программу движения ракеты снизу вверх. pascal abc...
anja565449
25.03.2019 07:20
Можно ли сказать что в своей сказке андерсен обращает внимание на проблему внутренней и внешней красоты.образы герды и снежной королевы сопоставить а также связать...
Популярные вопросы
Разобрать слово как часть речи ужин...
3
Из элементов, составляющих основную массу вещества клетки, первое...
3
Эпитеты и цитаты троекурова и дубровского...
1
18. употребите нужную форму глагола i m sure he’ll write to...
3
Фрагмент днк состоит из 200 нуклеотидов в обеих цепях, из них...
2
Объясните значение фразеологизмов одним словом. 1) бросить якорь...
3
Закончи предложения висят полки на идут полки в какой ты можешь...
2
Углерод по содержанию елементов в клетке занимает второе место...
3
What can you see in the fields and forests?...
1
Начерти два отрезка длиной 3 см а второй длинее первого на 1...
1
namespace Test
{
public class Program
{
public static void Main(string[] args)
{
double a,b,c,D,x1,x2;
a=double.Parse(Console.ReadLine());
b=double.Parse(Console.ReadLine());
c=double.Parse(Console.ReadLine());
D=b*b-4*a*c;
if(D>=0){
x1=(-b+Math.Sqrt(D))/(2*a);
x2=(-b-Math.Sqrt(D))/(2*a);
Console.WriteLine("x1="+x1+"; x2="+x2);
}
else Console.WriteLine("нет корней"); }
}
}