Программа в паскале! "напишите программу, которая в последовательности целых чисел определяет сумму максимального и минимального чисел . программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом ноль (ноль – признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введенные числа по модулю не превышают 30000." отдал все пункты что есть! !

Saxarok2018 Saxarok2018    3   21.05.2019 16:50    7

Ответы
dzhulijamalish dzhulijamalish  16.06.2020 11:55

uses System;
var ch,min,max,i:integer;
begin cls;

readln(ch);
min:=ch;
max:=ch;

while(ch<>0) do
begin
readln(ch);
if ((min > ch) and (ch<>0)) then min:=ch;
if max < ch then max:=ch;
inc(i);
if i > 999 then break;
end;

writeln('max = ', max);
writeln('min= ',min);
writeln('suma max + min = ',max+min);
readln;
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика