tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Программа в pascal abc вводится
Программа в pascal abc вводится последовательность натуральных чисел. признак конца ввода – число 0. определить количество чисел кратных 2 и 3 и сумму всех введенных чисел.
Карина12345654321
3 26.05.2019 19:20
2
Ответы
РашеваГулим
23.06.2020 08:13
Program pr;
uses crt;
Var k,a,sum:integer;
Begin
Writeln('Vvedite posledovatelnost');
k:=0;
readln(a);
sum:=a;
While a<>0 do
Begin
readln(a);
sum:=sum+a;
if (a mod 2=0) and (a mod 3=0) then k:=k+1;
end;
Writeln('k=',k);
Writeln('sum=',sum);
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
RepchatiLuchochek
15.03.2020 03:09
Как исправить программу? паскаль АВСзадание:найти среднее арифметическое введенных чисел (числа вводятся до тех пор, пока не будет 0)var N,a,S,i:integer; SR:real;begin...
polinaroshupkina
15.03.2020 03:08
решить Информатику Хотя бы 3 задания...
jak15
15.03.2020 03:05
Как исправить программу? паскаль АВС задание: посчитать количество отрицательных и положительных чисел (с клавиатуры вводят последовательность чисел до тех пор, пока...
wkolo3avr211
15.03.2020 03:05
По условию предыдущей задачи, если значение периметра меньше 100, увеличьте его значение в 2 раза, иначе на 10. Используя оператор...
13049822987546
15.03.2020 03:02
ответ должен быть желательно к завтрашнему утру. (больше не получается, увы) (Письменное условие: В программу вводится случайное число, если это число больше нуля,...
Hiipotatohihi
11.09.2019 13:10
Для записи текста использовался 64- символьный алфавит. какое количество информации в байтах содержат 10 страницы текста, если на каждой странице расположено 32 строки...
сдаддае
13.07.2019 23:40
Втаблице запросы к поисковому серверу. для каждого запроса указан его код – буква от а до г. расположите коды запросов слева направо в порядке возрастания количества...
lilarthur
13.07.2019 23:40
Объясните ошибку в следующей записи на языке паскаль. x = 0 and round(sqrt(x)) mod 2 =0....
vasilchenko17
13.07.2019 23:40
Сколько существует различных наборов значений логических переменных x1,x2,x3,x4,x5,x6,x7,x8,x9,x10, которые удовлетворяют всем перечисленным ниже условиям? x1 /\ (x2...
val40
17.05.2019 15:10
Монитор позволяет получать на экране 2 в 24 степени цветов. какой объем памяти в байтах требуется для кодирования 1 пикселя?...
Популярные вопросы
Заполните таблицу (анеба обыкновенная, эвглена зелёная, инфузория...
3
Popcypap1) (3x+y)-(x-4у); 2) (x+6y)-(8х-у); 3) (m+n)+(т-п); можете...
2
Уменя кр. нужно объяснить слова и почему слово лишнее...
3
Даны вектора а и b [а]=4 , [b]=5 угол между векторами равен 135...
3
Участие воды в процессах осмоса в клетке связано с: 1.полярностью...
1
Имеются водные растворы цианида калия, нитрата натрия, хлорида алюминия....
3
Степной ветер собрал за доном с полевых дорог тонкую сеяную пыль...
3
15 мини --рассуждение на тему у каждой победы есть свои имена ...
3
Сочинение на тему опасные приключения...
2
Какое количество вещества содержится в 5 кг водорода h2...
2
uses crt;
Var k,a,sum:integer;
Begin
Writeln('Vvedite posledovatelnost');
k:=0;
readln(a);
sum:=a;
While a<>0 do
Begin
readln(a);
sum:=sum+a;
if (a mod 2=0) and (a mod 3=0) then k:=k+1;
end;
Writeln('k=',k);
Writeln('sum=',sum);
readln;
end.