tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Программа в pascal abc:
Программа в pascal abc: дано натуральное число. определить: а) количество цифр в нем; б) сумму его цифр; б) сумму квадратов его цифр.
ЮлияСтоянова
3 17.08.2019 00:50
3
Ответы
lingvini2013
04.10.2020 23:43
Б)program up1;
var q,w:integer;
begin
write('введите число');
read(q);
while q>o do
w:=q mod10;
w:=w+w;
q:=w div 10;
end;
write('сумма цифр числа равна',w);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
вика3878
30.04.2020 16:22
Чему равно значение переменной s в результате выполнение программы Program mas; Var s,m: integer; Arry B[1..6] of integer; Begin s:=0; For m:=1 to 6 do begin B[m]:=m*m; If B[m]...
maz156
26.03.2020 20:42
И последнее задание. с цветных карточек передают информацию. Сколько минимум в различных цветов нужно использовать, чтобы с четырех карточек получить не менее 260 различных сигналов?...
rusakova09
26.03.2020 20:44
В кодовом замке используются цифровые переключатели, стоящие цифры в десятичной системы счисления. Сколько минимум переключателей должен содержать замок,чтобы можно было предусмотреть...
НастяЛайк111
22.10.2020 13:25
Закодируйте слово САЙТ в двоичной и десятичной системе счисления, используя таблицу ASCII...
zudavaikin
22.10.2020 13:25
4. Переведите координаты точек в 10-ую CC и постройте рисунок в координатной ПЛОСКОСТИ.101, 101) 2010, 110) 3(101, 110) 4(111, 1001)5(1001, 1001) 6(111,110) 7(1010, 110) 8(1011,...
Darina0090
22.10.2020 13:25
4. Компьютерлік вирустарды әсер ету дәрежесіне байланысты қалай жіктеугеболады? можно побыстрее ...
sdtyvbv
22.10.2020 13:25
с контрольной задания на фото и напишите вычесление для каждого задания,...
demorgan512
22.10.2020 13:25
Перед тобой число в двоичной системе укажи какое это число в десятичной системе 1001 2349...
ratmir10
15.12.2021 10:44
Практическая работа Инвариант цикла Определите инвариант цикла для следующего алгоритма двоичного поиска...
Arina0903
26.10.2020 18:53
с СОЧем по информатике,7класс...
Популярные вопросы
Найдите значение выражение: 7/5: (-1/4+1/2) -2...
1
Подбери синонимы к словам родина труд...
2
Синтаксический разбор предел. его всюду искали, но он убежал, наверное, навсегда...
2
Где допущена грамматическая ошибка? - марина одела красивое платье. - мы торопились,...
3
Костюм стоил 2000 рублей. его цену повысили на 5%, а потом снизили на 10%. сколько...
1
Найдите углы, которые получаются при пересечении двух прямых, если сумма двух...
1
Втональності ля бемоль мажор побудувати мvii7...
3
Вставь правильную форму глагола do или does 1. you like summer? 2. mark like...
3
Два пешехода вышли одновременно в противоположных направлениях из одного пункта....
2
Іль скласти невелику казку про їжачка...
3
var q,w:integer;
begin
write('введите число');
read(q);
while q>o do
w:=q mod10;
w:=w+w;
q:=w div 10;
end;
write('сумма цифр числа равна',w);
end.