Программа с ! составьте программу, которая по введенному вами k-число грибов, печатает фразу: "мы нашли в лесу k грибов" причем согласовывает окончание слова «гриб» с k.!

kurbatovmaximp08xa1 kurbatovmaximp08xa1    1   20.05.2019 18:30    3

Ответы
ConyaMiMiMi ConyaMiMiMi  14.06.2020 05:49

var k:integer;
begin
writeln('Input number of mushrooms: ');
Readln(k);
if k=1 then Writeln('Mi nashli ',k,' grib')

else
if (k=2) or (k=3) or (k=4) then Writeln('Mi nashli ',k,' griba')

else
Writeln('Mi nashli ',k,' gribov');
readln;
end.

ПОКАЗАТЬ ОТВЕТЫ
6vyvu 6vyvu  14.06.2020 05:49

var

  count:integer;

begin

  write('Введите количество грибов '); readln(count);

  write('Мы нашли в лесу ', count);

  case count div 10 of

    1: writeln(' грибов');

    else

      case count mod 10 of

        0, 5..9: writeln(' грибов');

        1: writeln(' гриб');

        2..4: writeln(' гриба');

      end;

  end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика